SigninLogs | mv-expand AuthenticationDetails = parse_json(AuthenticationDetails) | where TimeGenerated > ago(120d) | where AuthenticationDetails.authenticationMethod == "Text message" | project UserPrincipalName, AuthenticationDetails.authenticationMethod, AuthenticationDetails.authenticationMethodDetail | summarize count()by UserPrincipalName
